Jump to content
Arno67

Servo qui saccade

Recommended Posts

bonjour à tous,

 

J'ai un soucis qui me fait des cheveux blancs... je possède un Trex700 E DFC équipé comme suit: Dominator MX850, castle ice2 160, bavarian demon 3SX, bec Mttec, 3X Xpert3301 HV, récepteur spektrum AR7700 avec satellite branché dans le BD.

Un servo cyclique ( a l’arrière) saccade fortement lorsque j’actionne la profondeur, mais avec du collectif aucun soucis, il reste linéaire. Voir vidéo ci-jointe. J'ai essayé, en le débranchant du BD, de le brancher dans une prise auxiliaire du AR7700 et la plus aucun soucis. sur le bec je peux modifier le voltage de sortie, plus j'augmente le voltage, plus il saccade. donc je n'ai pas d'idée sur la source du problème, a mon avis le servo fonctionne bien, il doit y avoir soit un probleme de fréquence, ou voltage.

Vos idées, conseils ou solutions seront les bienvenus.

 

A bientôt

Share this post


Link to post
Share on other sites

Salut,

 

peu être une tension trop forte pour ce servo. si tu l'augment il saccade plus mais que lorsque tu met du collectif, il y a les 3 servos qui fonctionne donc légère chute de tension ce qui soulage ce servo..

en combien de volt ton bec est réglé ?

 

A++

Share this post


Link to post
Share on other sites

as-tu essayé de le brancher sur une des deux autres entrées des servos cycliques du bavarian ?   (sans mettre l'hélico en vol...)

Edited by jmb74

XK110, Lynx Oxy 2, Protos 380, Protos 500, Logo 550, Protos 770, Protos 800 evoluzione, Hughes MD500/Trex 700

Share this post


Link to post
Share on other sites

bonne idée... alors en mettant ce servo sur l'AC, aucun soucis. en mettant le servo cyclique gauche a la place de celui la, il saccade comme l'autre... au final mes servos sont bons, il doit y avoir un truc au niveau de la sortie servos du bavarian, ou alors un reglage a faire quelque part 

Share this post


Link to post
Share on other sites
Il y a 4 heures, Arno67 a dit :

bonne idée... alors en mettant ce servo sur l'AC, aucun soucis. en mettant le servo cyclique gauche a la place de celui la, il saccade comme l'autre... au final mes servos sont bons, il doit y avoir un truc au niveau de la sortie servos du bavarian, ou alors un reglage a faire quelque part 

Voila une bonne avancée vers la résolution du problème, les servos sont donc ok. Je ne connais malheureusement pas le bavarian, mais je suppose qu'il est possible de configurer la fréquence (Hz) et la largeur d'impulsion (ms) des servos. Ces paramètres sont-ils en concordance avec les caractéristiques des servos ?

Attention, généralement le servo d'ac a des caractéristiques différentes des servos du cyclique.

Si la configuration des servos est correcte, il serait judicieux de réinitialiser complétement le bavarian.

Deux méthodes, soit sauvegarder la configuration, réinitialiser le bavarian, puis recharger la configuration depuis la sauvegarde, soit réinitialiser le bavarian et repartir à zéro...

Edited by jmb74

XK110, Lynx Oxy 2, Protos 380, Protos 500, Logo 550, Protos 770, Protos 800 evoluzione, Hughes MD500/Trex 700

Share this post


Link to post
Share on other sites

Bonsoir Arno 67,

a ma connaissance il n'est pas possible de configurer fréquence et impulsions sur le 3X, mais vérifie  sur la page RC du bavarian que tu as bien coché la case numérique pour le servo AC (deuxieme page après Accueil ....je pense que ça n'a pas été fait ! ! 

 

Nanar


Lama Electrique 2m /  Gazelle Vario version électrique 2.3m / Trainer Raptor E700 Electrique /Drone Mavic mini /Agusta AW139 Vario électrique /Robinson R66 Turbine/.....

Share this post


Link to post
Share on other sites

hello,

 

Alors pour vous répondre à tous les deux, les servos sont bien en numérique, j'ai cependant trouver une amélioration, il faut jouer sur les réglages de la page RIGID, au niveau de la sensibilité, agilité et P-taux. ca me donne des servos beaucoup plus linéaire, reste a voir en vol si ca ne change pas le comportement.

merci de votre aide

Share this post


Link to post
Share on other sites

Arno67,

 

si tes valeurs de réglage du menu Rigid sont farfelus, tu vas crasher ton hélico.

 

Tu devrais plutôt refaire un réglage complet du 3SX, sait on jamais, ça peut régler ton problème.

 

Si ton problème persiste, il faut contacter le sav Bavarian. Non, ce n'est pas normal que le 3SX donne des ordres saccadés sur la commande de profondeur.

 

PS : ton hélico a déjà volé dans cette configuration ?


Steph 66 moniteur hélico RC à Argelès => http://www.stageaeromodelisme.com

Beam AvantGarde / Spectra-G / XCell Fury / Fury 55 / Trex 500 GF FBL BeastX / Trex 450 PRO FBL BeastX / Protos BeastX / MiniProtos BeastX

Share this post


Link to post
Share on other sites

steph66,

 

L'hélico volait très bien avec le servo en saccade, seulement quand on voit un servo bouger comme ça, on a pas envie de continuer, risque de casser le servo et/ou la machine. le BD est réglé correctement, je ne vois pas comment en le réinitialisant ça peut changer les choses, j'ai refait les réglages depuis le début. un peu plus tard, je vais poster un screenshot de la page rigid, ceux qui ont un 3sx pourront comparer ces valeurs si elles paraissent normales ou pas. Après, en statique tout fonctionne bien et dans le bon sens.

Share this post


Link to post
Share on other sites

Ta première vidéo n'a que du son sur mon ordi, et pas de vidéo.

 

Ton problème de servo de profondeur qui bouge de manière saccadé, c'est en vol ou à l'atelier ?


Steph 66 moniteur hélico RC à Argelès => http://www.stageaeromodelisme.com

Beam AvantGarde / Spectra-G / XCell Fury / Fury 55 / Trex 500 GF FBL BeastX / Trex 450 PRO FBL BeastX / Protos BeastX / MiniProtos BeastX

Share this post


Link to post
Share on other sites

le servo saccade a l'atelier, en vol je ne sais pas, mais le comportement de l'hélico est normal. voici une photo des mes parametre dans le BD. avec ces réglages, le servo ne saccade pas. j'ai changé de quelques points seulement le : gain elevator, elevator filter et D-fonction.

119147193_448655712736436_8019948947282595880_n.jpg

Share this post


Link to post
Share on other sites
Le 12/09/2020 à 09:55, Arno67 a dit :

le servo saccade a l'atelier, en vol je ne sais pas, mais le comportement de l'hélico est normal.

J'ai pu lire ta vidéo (ça ne passait pas sur mon Firefox ...)

 

Il me semble que ce n'est pas 1 servo qui saccade mais bien les 3, quand tu actionnes la profondeur. Tu dis que tout se passe bien en vol malgré cela ?

 

Vérifie depuis par exemple le logiciel du Bavarian si la position de ton manche de profondeur est bien lue, et les mouvements fluides.


Steph 66 moniteur hélico RC à Argelès => http://www.stageaeromodelisme.com

Beam AvantGarde / Spectra-G / XCell Fury / Fury 55 / Trex 500 GF FBL BeastX / Trex 450 PRO FBL BeastX / Protos BeastX / MiniProtos BeastX

Share this post


Link to post
Share on other sites

Salut Arno67. Si Steff 66 a bien vu les 3 servos qui saccadent cela voudrai dire que la "fréquence de rafraîssissement " des servos du cyclique et affiché par tes soins sur le bavarian n'est pas la bonne (certainement trop elevé) Si tu ne connais pas cette fréquence, tu peux la trouver sur "wiki.beastx.com"  . A moins d'être hyper connaisseur du bavarian, ne touche pas au gain elevator, elevator filter et d.fonction car ces valeurs sont parametrés d'office lors que tu as rentré les caractéristiques de l'hélico et sont adaptées à ces caractéristiques pour effectués un vol sans problémes (il faut faire confiance aux ingénieurs de chez CAPTRON). Cdt Snake


Bell UH1, Alouette 2 et 3, Hugues 500, Super Puma, Ecureuil, Schweitzer 300 Caliber 5, Predator, Agusta, BO 105 CBS en préparation.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Copyright 2002-2017 par FRANCE-HELICO.COM

France-Helico est un site créé sans but commercial par des passionnés de l'hélicoptère.
×